Guide :Grilling : Genesis Silver B Grill

Ignite prob I have 3 yr old Silver B Weber. This is first yr I've kept covered outside all winter. (snow & rain, Indiana) Now I'm trying to use 1st time since last fall. When I turn on gas (full tank), open burner valve, ignite spark. Nothing! When I use manual fire lighter just the first (front burner) ignites (other 3 burners don't ignite when valves opened). Is there a method to clean out burners or something? Need new spark igniter?

Posted by indygary on Mar 03, 2008

Research, Knowledge and Information :


Full text of "NEW" - Internet Archive


movies All Video latest This Just In Prelinger Archives Democracy Now! ... This Just In Grateful Dead Netlabels Old Time Radio 78 ... Full text of "NEW" See other ...
Read More At : www.archive.org...

Suggested Questions And Answer :


Ignite prob I have 3 yr old Silver B Weber. This is first yr I've kept covered outside all winter. (snow & rain, Indiana) Now I'm trying to use 1st time since last fall. When I turn on gas (full tank), open burner valve, ignite spark. Nothing! When I use manual fire lighter just the first (front burner) ignites (other 3 burners don't ignite when valves opened). Is there a method to clean out burners or something? Need new spark igniter?


You've got two different things going on.  First - the type of igniter used on your model does wear.  I have had mine for over 10 years and have gone through 3 such igniters - and I grill nearly 3 times per week over the 25 week "grilling" season where I live. Spring for the $12 part and just replace it. The other issue sounds like a clogged cross-over system.  I would remove the burners, including the cross-over bar on the far left side that connects them.  Clean the exterior with a stiff steel/brass brush and the inside with a bottle brush.  Make sure all the holes are clear to allow gas to flow easily - use a wooden tooth-pick to do this to make sure you don't change the size of the holes! Put that baby back together and I think you'll find you'll be good as new! These grills are great.  Now, if Weber could only fix the uneven heat problem between the left and right side I'd REALLY be happy!  (I wish they would even just admit there IS a problem!) Good luck and happy grilling.
Read More At : Genesis Silver B Grill...

Hello, I had to clean my grill and in doing so I removed the burners. After putting it back together, the burners will now ignite when trying to use the igniter switch. I can ignite them by use of a lighter. I did notice there is a spark where the wire goes into the knob area, I did not see one a spark at the end of the electrode closest to the burner. I did get shocked by the electrode as I hit the igniter switch. Any assistance would be appreciated. Thanks, Bob.


The ignitor(s) have apparently lost their ground. You may have disturbed a wire(s) when you removed the burners to clean them. Trace the wiring to each of the peizo ignitors (what the spark comes off of) and make sure they are tight (pushed up on the prong of the piezo) Also, where you saw the spark, remove the wire and reattach it. It is probably lose. The ignitor button/assembly is grounded to the grill frame. Make sure it's attached tightly.Once you correct the parking wire, I think you will have solved the problem.Happy Grilling!!
Read More At : Weber...

Problem with gas getting to the front burner


Follow manufacturer's recommendation in resetting the excess flow safety device....(Turn burners and LP cylinder off...Disconnect regulator on cylinder. Turn both knobs to high for at least one minute...Then turn them to off...reconnect the regulator to the LP tank...Turn LP valve VERY slowly (30 seconds) until fully opened..then start the grill in the usual manner. ALWAYS TURN THE LP TANK OFF WHEN DONE USING THE GRILL....
Read More At : Genesis Silver B Grill...

The Front burner lights but only a small blue flame appears.


It sounds like it needs a good clean!
Read More At : Genesis Silver A Grill...

The ignitor does not work. I am able to start a flame by inserting a match and then turning on the burner knob. Either first, middle or back. Is there a AA battery that is used to create a spark for the ignitor ???


Your grill uses a push button piezo type of igniter. Each time you push the button you should her a click and a an electrical charge should be sent down a wire to an electrode where a spark will jump from the tip of the electrode to the nearest metal surface creating a spark to ignite the gas. The first thing to do is make sure the wire from the electrode to the igniter is actually connected to the igniter. Then make sure the wire is connected to the electrode. Make sure there are no breaks in the wires insualtion that could cause a short. Check the electrode and make sure it is held securly in place and not moving around. Check the ceramic white insualtor for breaks or cracks casuing a short. If all of this is ok, then it is most likely the igniter itself. You can get a replacement at www.minxenterprisesinc.com for $9.49 plus tax and shipping.
Read More At : Genesis Silver B Grill...

I have a weber grill & when you turn on front burner to the ignite position no gas is coming out to be ignited. If I turn on the back burner I can hear & smell it. How do I get the front burner to work again?


You have a spider web in the orifice or a ant unblock it then you are ready to go
Read More At : Genesis Silver B Grill...

Back burner won't light on my Weber Genesis Silver A Gas Grill


Only front burner lights (out of three) and it only has flame comming out of half of the tube.
Read More At : Genesis Silver A Grill...

Have a PF-27G, erroneously shipped to Hawaii with connection for Nat gas. Replaced orifices and electrodes to convert. Having problem with igniter not sparking and technician here told me to get the igniter sparking, and then turn on burner knob to lite and hit igniter button again. Doesn't seem to make much sense. Don't have a rotating igniter knob and using propane


If you can light the burners manualy then recheck gap distance on electrodes and on igniter. If gap is to close or to fare this will cause a problem.
Read More At : PF27G Grill...

Two burners run too hot with yellow flame.


Hello,It sound like your back burners have a partial blockage or possibly are rusting or falling apart or have cracked seams. Remove the cooking grids and burner shields, and examine the burners closely. If you can't find a blockage inside (spider web, bugs nest, etc) then their condition is probably deteriorating. Let us know if you need more assistance.
Read More At : Genesis Silver B Grill...

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.
next Question || Previos Question
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.mainebirdfood.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0432 seconds